Home  |  Forums  |  914 Info  |  Blogs
 
914World.com - The fastest growing online 914 community!
 
Porsche, and the Porsche crest are registered trademarks of Dr. Ing. h.c. F. Porsche AG. This site is not affiliated with Porsche in any way.
Its only purpose is to provide an online forum for car enthusiasts. All other trademarks are property of their respective owners.
 

Welcome Guest ( Log In | Register )

> Electrical Issue After Engine Drop
HerdofCrickets
post Aug 12 2019, 12:20 PM
Post #1


Member
**

Group: Members
Posts: 68
Joined: 23-September 16
From: Overland Park, KS
Member No.: 20,423
Region Association: None



Dropped the engine last fall, had it rebuilt and we put it back in a month or so ago.

After having a little boy a few months ago, I'm finally getting a little time to get back to work on the 914.

Engine itself runs great, exhaust is really rich... so I guess the carb needs adjusted a little.

One issue though... no power to the dash (tach doesn't work and radio doesn't turn on).

Also when I turn the key, the engine tries to turn over but only fires when you let off the key.

Pretty sure I must have a wire hooked up wrong...

I'll start working backwards tonight but if anyone has any ideas... that'd be fantastic!

-Jon
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 23rd August 2019 - 10:54 PM