Home  |  Forums  |  914 Info  |  Blogs
 
914World.com - The fastest growing online 914 community!
 
Porsche, and the Porsche crest are registered trademarks of Dr. Ing. h.c. F. Porsche AG. This site is not affiliated with Porsche in any way.
Its only purpose is to provide an online forum for car enthusiasts. All other trademarks are property of their respective owners.
 

Welcome Guest ( Log In | Register )

> Help; 1970 1.7l swap to a 74 1.8L, Having trouble getting it to run.
cbat
post Jul 14 2020, 07:26 AM
Post #1


Newbie
*

Group: Members
Posts: 5
Joined: 14-July 20
From: Massachusetts
Member No.: 24,495
Region Association: MidAtlantic Region



We have been working on a 1970 which came with 1.8L in from a 1974 car (L-jetronic) .

When received the car would hardly run due to the distributor advance being frozen. After repairs, it ran better but still lacked power so we did the following. Checked all the tune-up specs again, which did not help. Then started replacing things in hopes that money might solve the problem...it didn't work either. The following were replaced; points, condenser, cap, rotor, new injectors, plugs, wires, coil, head temp sensor, fuel pump, filter, aux air valve, dual relay, rebuilt airflow sensor, and I am sure a few other things.

As mentioned, it was running but poorly. I was down to the engine wire harness so it was sent out for rebuilding. Now it will not run at all.

This is what I have checked so far:
Fuel pump: runs when hooked up directly to the battery but not with the ignition.
Checked voltage at pin 88d while cranking..nothing
Checked voltage at 88y and do have voltage all the time
Checked 86a and no voltage while cranking

Could I have a bad starter switch?

Is the older relay board not compatible with the L-Jet?

If you should have any idea what my next stop should be please let me know. I need to get the Garage Queen running...

I appreciate any and all guidance....
Chris


User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 12th August 2020 - 03:39 AM